DebianでPlaggerを使う

deb http://debian.hansode.org/ ./
# aptitude update
# aptitude upgrade
# aptitude dist-upgrade
# apt-cache search plagger
# aptitude install libplagger-perl
# plagger -v
Plagger version 0.7.14

失敗

実は全然順調にいかなかった.apache2.2にupgradeされ,そのせいで ReverseProxyがうまく動かなくなったりして,大変だった.

# cd /etc
# mv apache2 apache2-1
# aptitude remove apache2
# aptitude remove apache2-mpm-worker
# aptitude remove apache2.2-common
# aptitude purge apache2.2-common

このようにして,まずApache2関係のファイルを一旦全部消した.

# aptitude install apache2
The following NEW packages will be installed:
 apache2 apache2-mpm-worker apache2.2-common 

このようにして,いれなおした. そうして設定ファイルを順番に書き直すと,うまくアクセスできるようになった.

最初のときになぜうまく動かなくなったのかは不明.設定ファイルをdiff -rで 見比べてみても,なにが原因だかはよくつかめなかった.

パッケージ情報の入手

apt Plaggerの削除

# aptitude remove libplagger-perl
  • 関連packageも同時に削除してくれる
  • 普通にCPANでいれてみることにしたよ…
Last modified: 2007-03-23